Two API endpoints returning incomplete data
Incident Report for GOV.UK Pay
Resolved
This issue is now fixed for all affected payments and the data provided if you query either endpoint is now complete.
Posted Jul 04, 2024 - 15:59 BST
Update
We've fixed this issue for the majority of affected payments and they are now returning complete data. We have a small amount of work to finish before we mark this as resolved and we hope to update the status tomorrow morning.
Posted Jul 03, 2024 - 16:41 BST
Identified
We're fixing an issue where two endpoints in the GOV.UK Pay API may be returning incomplete data. This only affects a small number of payments taken between Tuesday 25 June and Wednesday 26 June.

The affected endpoints are:
- GET /v1/payments/{PAYMENT_ID}/events - endpoint might return incomplete events data
- GET /v1/payments/{PAYMENT_ID} - endpoint might return incomplete fee (for Stripe payments) or settlement data

The impact this incident has on your service depends on how you use the GOV.UK Pay API. We believe this impact is low for affected services. If you do not integrate with our API you will not be impacted.

If you have any questions please email govuk-pay-support@digital.cabinet-office.gov.uk.
Posted Jul 02, 2024 - 17:03 BST
This incident affected: Public API.