Issue with viewing refunded transactions in Self Service

Incident Report for GOV.UK Pay

Resolved

We made some changes to the GOV.UK Pay admin tool, which prevented service users from viewing certain transactions, specifically where transactions had been refunded.

Affected service users were presented with an error page when they attempted to view certain individual transactions.

We rolled back the change earlier today. Errors stopped immediately on the revert being deployed. The incident is now closed.
Posted Oct 21, 2025 - 12:18 BST
This incident affected: Self Service.