Issue with Stripe recurring card payments

Incident Report for GOV.UK Pay

Resolved

Past agreements that were affected have now been fixed. Recurring payments can now be processed for the affected agreements and any new agreements.
Posted Sep 08, 2026 - 13:35 BST

Monitoring

We have deployed a fix. Newly created agreements are being activated as expected. We'll now begin correcting agreements that previously experienced issues.
Posted Sep 07, 2026 - 13:59 BST

Investigating

Stripe recurring card payment agreements are not being activated following the successful payment to set up agreement. The paying users’ first payment to set up the agreement is being completed successfully. Subsequent recurring payments on the same agreement are not being completed successfully. This is happening in 100% of Stripe recurring card payment transactions. We will contact affected services directly.

Worldpay recurring card payment transitions are not affected. One-off card payments for Stripe and Worldpay are not affected.

We are actively investigating the issue to identify the route cause. We will provide updates when we know more.
Posted Sep 07, 2026 - 10:09 BST