Issue with the using the admin tool to filter payments
Incident Report for GOV.UK Pay
Resolved
We've resolved this issue. If you are still experiencing problems, please contact us through the support email address.
Posted Dec 04, 2024 - 16:36 GMT
Monitoring
We've issued a fix to the transactions page to allow you to filter transactions and are monitoring for any further problems. If you are still experiencing problems, please contact us through the support email address.
Posted Dec 04, 2024 - 14:31 GMT
Identified
Some users may not be able to filter transactions in the admin tool. (We can confirm that you are still able to see all transactions in the list).

We’ve identified the issue and are issuing a fix to the problem.
Posted Dec 04, 2024 - 10:50 GMT
This incident affected: Self Service.