Issue with Worldpay causing payment errors
Incident Report for GOV.UK Pay
Postmortem

At 00:19 on Monday 20 July, payment service provider Worldpay started returning a high proportion of errors when processing payments. The service was degraded until 16:15, and for some of that period as many as 90% of Worldpay payments through GOV.UK Pay were failing.

This was the most significant payment service provider outage in GOV.UK Pay’s history.

GOV.UK Pay has a 30 minute response time to incidents that degrade performance to this extent. However, this does not apply to problems caused by upstream services where the team has no ability to resolve the issue. Our alerts won’t wake up an engineer out of hours unless they’re going to be able to help resolve the problem.

We’ve identified some areas where our alerting could be improved to more quickly identify this rare type of outage.

We’re investigating how we can improve our status page to help service teams understand the cause of failures, including whether we can surface information about the availability of payment service providers on the GOV.UK status page automatically.

We’ve learned that different services have different understanding of the relationship between the service, GOV.UK Pay and the payment service provider. We’ll review our incident policy to see if there are useful interventions we can make to help services manage payment service provider outages, even when we can’t resolve the issue itself.

Posted Jul 22, 2020 - 09:40 BST

Resolved
Worldpay have communicated:
"Worldpay technical resources resolved an internal network error to restore service. Payments are approving at normal rates as of 15:15 UTC."

The incident has been resolved.
Posted Jul 20, 2020 - 19:35 BST
Update
We are seeing normal success rates. We will continue to monitor and will mark as resolved when Worldpay confirms that they have closed the issue.
Posted Jul 20, 2020 - 17:54 BST
Monitoring
Most payments are being successfully processed, and the number of errors we are seeing is low.

We are still monitoring the situation and will pass on any future updates from Worldpay.
Posted Jul 20, 2020 - 16:24 BST
Update
Most payments are now being processed successfully, but some are still failing.

Worldpay have communicated:
"Worldpay technical resources have identified an internal network error and continue to work to resolve the issue. At this time there is no Estimated Time to Resolution (ETR). Further updates will be provided as additional information becomes available."

We are monitoring the situation.
Posted Jul 20, 2020 - 14:20 BST
Update
The issue with Worldpay continues and transactions are failing.

Worldpay have communicated:
"There is a network issue impacting payment processing on the Access Worldpay and Worldwide Payment Gateway (WPG) platforms."

We're continuing to monitor this.
Posted Jul 20, 2020 - 12:16 BST
Identified
Worldpay are seeing an issue with payment processing. This has been happening intermittently since Saturday and may cause payment requests to fail. If this happens, an error message is shown to the user. Refunds may also be affected.

We are monitoring the situation.
Posted Jul 20, 2020 - 09:11 BST
This incident affected: Payment pages.