Google Pay downtime

Incident Report for GOV.UK Pay

Resolved

Google have resolved the issues, and we are seeing no further issues with Google Pay
Posted Sep 17, 2026 - 09:28 BST

Monitoring

Google have reported issues with Google Pay, which is affecting some users from seeing the Google Button on the payment pages. Users will still be able to pay using a card. We will continue to monitor Google's status page this evening and will provide a further update tomorrow morning. (17/9)
Posted Sep 16, 2026 - 17:32 BST
This incident affected: Google Pay.