Issue with CSV downloads

Incident Report for GOV.UK Pay

Resolved

The fix has been deployed, and we have seen CSV downloads working as expected, we will continue to monitor this issue this afternoon.
Posted Jul 02, 2026 - 14:09 BST

Identified

We have noticed a problem with CSV downloads for services that use Stripe. We have deployed a fix to resolve this issue. We will continue to monitor this and update you during the afternoon
Posted Jul 02, 2026 - 14:04 BST
This incident affected: Self Service.